MICROSOFT CORPORATION NON-DISCLOSURE AGREEMENT

(PRE-RELEASE INTERNET EXPLORER 5.x)

This Microsoft Non-Disclosure Agreement for Pre-Release Internet Explorer ("Agreement") is entered by and between Microsoft Corporation, a Washington corporation located at One Microsoft Way, Redmond, WA 98052-6399 ("MS"), and Recipient that agrees and accepts the following terms and conditions of this Agreement, by executing this Agreement where indicated below. UponMS' receipt of Recipient’s acceptance of the terms and conditions of this Agreement, MS may elect, at MS' sole discretion, to provide Recipient with one or more pre-release copies of Microsoft Internet Explorer version 5.x and content covering the authoring of and development for Internet Explorer ("Development Content"), with separate disclosures of individual components thereof, including those separately code-named, related documentation and related information such as passwords or account names necessary for Product distribution and use, (collectively the "Product"). MS may, in its sole discretion, also provide further pre-releases of the Product, components for the Product or related information to Recipient hereunder, in which case such further pre-releases of the Product, components of the Product and related information shall also be covered hereunder as "Product".

1. RIGHTS.

(a) License Grant.

    (i) Internet Explorer. MS grants to Recipient a limited, non-exclusive, nontransferable, royalty-free license to make and use up to five (5) copies of the executable code of Internet Explorer provided each such copy is used only on CPUs located on Recipient's premises at the address provided to MS, such use and copying being solely for purposes of testing the compatibility of Recipient’s application or other product(s) which operate in conjunction with Internet Explorer and evaluating Internet Explorer to provide feedback thereon to MS. All other rights are reserved to MS.

    (ii) Development Content. MS grants to Recipient a limited, non-exclusive, nontransferable, royalty-free license to make and use a sufficient number of copies of the executable code of the Development Content on computers located on Recipient's premises at the address provided to MS. Recipient may use such copies of the Development Content only for the purpose of developing and authoring test versions of websites that operate with Internet Explorer, and to provide feedback thereon to MS. Recipient may only host such websites internally for testing and evaluation and may not post such websites for public use until Recipient has acquired the final commercial release of the Development Content. Use of the Development Content for the purposes of developing, authoring, and posting Recipient public websites utilizing the Development Content shall be subject to the license agreement accompanying the final commercial release of the Development Content. All other rights are reserved to MS.

(b) License Restrictions/Ownership of Product. Recipient acknowledges that MS will not be obligated to make the Product available as a final commercial product Recipient shall not rent, lease, sell, sublicense, assign, or otherwise transfer the Product, including any accompanying printed materials. Recipient shall not reverse engineer, decompile or disassemble the Product except to the extent that this restriction is expressly prohibited by applicable law. MS and its suppliers shall retain title and all ownership rights to the Product.

(c) Feedback. Recipient agrees to provide reasonable feedback to MS, including but not limited to usability, bug reports and test results, with respect to the Product testing. Recipient will use reasonable efforts to review and comment on all documentation supplied. All bug reports, test results and other feedback made by Recipient shall be the property of MS and may be used by MS for any purpose. Due to the nature of the development work, MS is not certain as to when errors or discrepancies in the Products may be corrected.

(d) Disclosure/Use on Recipient’s Site. Recipient may disclose the Product only to its employees who have a need to know in order to accomplish the purposes identified in Section 1(a), and such employees' use of the Product shall take place solely at Recipient's site. Recipient will have executed appropriate written agreements with its employees sufficient to enable it to comply with the terms of this Agreement. Recipient agrees that, for a period of up to six (6) months after commercial release of the Product, it will maintain a list of all employees who have had access hereunder to the Product or related information.

2. TERM OF AGREEMENT. The term of this Agreement shall commence as of the date Recipient indicates its acceptance of the terms and conditions of this Agreement and shall continue until terminated by (a) MS’ written notice to Recipient, (b) the commercial release of the Product by MS, or (c) one year after receipt of the Product by Recipient, whichever occurs earlier. Upon the termination of this Agreement, Recipient shall cease use of the Product and shall promptly return all copies thereof to MS, or certify destruction of, all full or partial copies of the Product and related materials provided by MS. The provisions of Section 5 shall survive termination or expiration of this Agreement with respect to any information that has not been made public by MS.

3. COST OF TESTING. There is no charge to Recipient for testing of the Product. MS shall bear all transportation expenses relating to shipment of the Product to Recipient's place of business and Recipient will pay any return transportation expenses. In the event the Product is distributed via the Internet, the cost of download is the sole responsibility of the Recipient, unless otherwise specified by Microsoft.

4. PRODUCT MAINTENANCE. MS is not obligated to provide maintenance or updates to Recipient for the Product. However, any maintenance or updates provided by MS shall be covered by this Agreement.

5. CONFIDENTIALITY. The Product and related information along with any information relating to the Product that Recipient may receive from private support newsgroups is proprietary and confidential information to MS and its suppliers. Recipient agrees not to disclose or provide the Product, documentation, or any related information (including the Product features or the results of use or testing) to any third party or use the Product for any purpose other than as provided in this Agreement. However, Recipient may disclose confidential information in accordance with judicial or other governmental order, provided Recipient shall give MS reasonable written notice prior to such disclosure and shall comply with any applicable protective order or equivalent. Recipient shall not be obligated to maintain the confidentiality of information which Recipient can prove (i) is already known to Recipient without an obligation to maintain the same as confidential; (ii) becomes publicly known through no wrongful act of Recipient; (iii) is rightfully received from a third party without breach of an obligation of confidentiality owed to MS; or (iv) is independently developed by Recipient.

6. DISCLAIMER OF WARRANTY. Product is deemed accepted by Recipient. The Product constitutes pre-release code and may be changed substantially before commercial release. The PRODUCT is provided "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT FURTHER DISCLAIMS ALL WARRANTIES, INCLUDING WITHOUT LIMITATION ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NONINFRINGEMENT. THE ENTIRE RISK ARISING OUT OF THE USE OR PERFORMANCE OF THE PRODUCT AND DOCUMENTATION REMAINS WITH RECIPIENT. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL MICROSOFT OR ITS SUPPLIERS BE LIABLE FOR ANY CONSEQUENTIAL, INCIDENTAL, DIRECT, INDIRECT, SPECIAL, PUNITIVE, OR OTHER DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR OTHER PECUNIARY LOSS) ARISING OUT OF THIS AGREEMENT OR THE USE OF OR INABILITY TO USE THE PRODUCT, EVEN IF MICROSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO RECIPIENT.

7. GOVERNING LAW; ATTORNEYS FEES. This Agreement shall be governed by the laws of the State of Washington and Recipient further consents to jurisdiction by the state and federal courts sitting in the State of Washington. If either MS or Recipient employs attorneys to enforce any rights arising out of or relating to this Agreement, the prevailing party shall be entitled to recover reasonable attorneys' fees.

8. U.S. GOVERNMENT RESTRICTED RIGHTS. The Product is provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data and Computer Software clause of DFARS 252.227-7013 or subparagraphs (c)(i) and (2) of the Commercial Computer Software -- Restricted Rights at 48 CFR 52.227-19, as applicable. Manufacturer is Microsoft Corporation, One Microsoft Way, Redmond, WA 98052-6399.

9. EXPORT RESTRICTIONS. Recipient agrees that it will not export or re-export Product to any country, person, entity or end user subject to U.S. export restrictions. Recipient specifically agrees not to export or re-export Product (i) to any country to which the U.S. has embargoed or restricted the export of goods or services, which currently include, but are not necessarily limited to Cuba, Iran, Iraq, Libya, North Korea, Sudan and Syria, or to any national of any such country, wherever located, who intends to transmit or transport the products back to such country; (ii) to any end-user who Recipient knows or has reason to know will utilize Product in the design, development or production of nuclear, chemical or biological weapons; or (iii) to any end-user who has been prohibited from participating in U.S. export transactions by any federal agency of the U.S. government.

10. ENTIRE AGREEMENT. This Agreement constitutes the complete and exclusive agreement between MS and Recipient with respect to the subject matter hereof, and supersedes all prior oral or written understandings, communications or agreements not specifically incorporated herein. This Agreement may not be modified except in a writing duly signed by an authorized representative of MS and Recipient.

11. PARTIES BOUND. If Recipient is executing this Agreement on behalf of an entity, then Recipient represents that he/she has authority to execute this agreement on behalf of such entity and agrees that Product (and any copies thereof) shall remain on the company premises, unless otherwise agreed by MS.

Recipient may indicate its acceptance of the foregoing terms by signing where indicated, and returning the document to the address below.

RETURN by mail to:

Microsoft Corporation

Attn: MS Beta Team 21/1

One Microsoft Way

Redmond, WA 98052-6399

OR

FAX to:

Microsoft Corporation

Attn: MS Beta Team 21/1

(425) 936-7329

Beta Site ID

Company Name

Recipient (signed)

Recipient Name (printed)

Principal Address (no P.O. numbers)

City, State, Zip

Phone Number

Internet Email Address

Date Signed